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SETUP PROCEDURE 

• Start the Altium Designer Software. (Figure 1) 
• Ensure that the ‘Files’ and ‘Projects’ tabs are located somewhere on the screen. Most likely they will be minimized 

on the left side of the window. If they are not then add them to the screen 
 a. View > Workspace Panels > System > Files 

 b. View > Workspace Panels > System > Projects 
 Alternatively you may…(Figure 2) 
 c. Click on the ‘System’ box in the lower right hand corner of the designer and then click ‘Files’ and 
 ‘Projects’ to make the tabs appear. 
These will both accomplish the same goal of making the ‘Files’ tab and the ‘Projects’ tabs visible. All tabs can be dragged 
and dropped nearly anywhere on the designer to suit your personal preferences. 
• Create a new PCB Project. File > New > Project > PCB Project – or – You may click on the ‘Files’ tab and then 

under the ‘New’ heading you can click ‘Blank Project’ (Figure 3) 
This will cause the ‘Projects’ tab to open and ask to set the name of the project. We may want to change the name and 
location of our project otherwise it will save as ‘PCB1.PcbDoc’ in default location. (Figure 4) 
• We will now add a schematic and a PCB to the current project. 
  Right click on the project > Add New to Project > Schematic (Figure 5) 
  Right click on the project > Add New to Project > PCB (Figure 6) 
Finally, we should save the generated files: 
 Right click on the name of each file>save (Figure 7,8,9)   
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Figure 3 
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Figure 6 
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Figure 7 
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Figure 8 



SETUP PROCEDURE 
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Figure 9 



ADDING LIBRARIES 

• Libraries are a very important part of working with your schematic. Libraries are where all of your parts will be found and 
selected from. If you do not have the ‘Libraries’ tab anywhere on your screen you should… 

 Click the ‘System’ box in the bottom right portion of the designer and then click the ‘Libraries’ button. (Figure 10) 

The Libraries panel enables you to browse and place components from the libraries currently available in Altium Designer 
The libraries that are listed are dependent on how the libraries were left the last time the designer was used. Since the 
computers in the lab are shared there is a possibility that the libraries that you would like to use are not listed. 
Components are categorized according to the manufacturers. They can be found in the address below:  
C:\program files (x86)\Altium\AD14\Library 

• The libraries that we will be using for this tutorial are: 
a. Miscellaneous Connectors.intlib 
b. ece component library.intlib 

Integrated libraries combine schematic libraries with their related PCB footprints  
• First download these libraries from Cecil and then install them to Altium as shown below.These can be added under Project 

tab or Installed tab.  
• Project libraries are availlable only for the active project whereas installed libraries are available for all the projects. In this 

exercise , we are adding them under Project tab. 
i. Open library panel and select project tab. (Figure 14) 
ii. Click on ‘add library’ button and browse your computer to find the libraries you need. (Figure 15) 
iii. You can see a list of your project libraries on the left side of the Altium page in projects tab. 
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Figure 10 
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Figure 11 
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Figure 12 
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Figure 13 
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Figure 14 
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Figure 15 



SCHEMATIC PRACTICE 
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ADDING PARTS AND MODIFYING THE SCHEMATIC  

• Add a resistor to you schematic page by following these steps (below image has red 
letters corresponding to the steps illustrated): 

a. Make sure you have your schematics page opened 

b. Open the ‘Libraries’ tab 

c. Select the ‘ece component’ library from the upper drop down (if this library is not in 
the drop down refer to previous step) 

d. Type ‘Res1’ into the dropdown textbox below the library listing 

e. Click the ‘Place Res2’ button at the top of the libraries tab 

f. Your cursor will then have a resistor attached to it and you can place it anywhere on 
the schematic 

g. Once you have placed the resistor you can either hit the ‘Esc’ key –OR- right click 
your mouse to stop placing resistors 
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ADDING PARTS AND MODIFYING THE SCHEMATIC  

• Follow the above steps and place 
the following parts 

a. From the ‘ece component’ library: 
i. (5) res2 
ii. (1) Cap 1-10uF TH 
iii. (1) Cap 

b. From the ‘Miscellaneous Connectors’ 
library: 

i. (1) Header 2H 
ii. (2) Header 2 

c. Search the libraries to find and place: 
(1) LM358N  

How to search? See more… 
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SEARCH IN LIBRARIES 
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a. Open ‘Libraries’ and select ‘search’ 
b. In first row, change operator to ‘contains, 

then write ‘LM358N’ in Value tab 
c. Make sure select ‘Libraries on path’ in 

Scope  
d. Brows and find the library path as: 
 C:\program files (x86)\Altium\AD14\Library 

e. Press ‘Search’, it takes few seconds to find. 
 

Note: make sure the dropdown textbox below 
the library listing is cleared, otherwise your 
search may not get result. 
 
f. You may find few models which are from 

different manufacturers with different 
footprints. 

Choose the one match to your design.   
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• Once you press ‘Place LM358N’, Altium will ask you if you want to install the related library or 
not. you should choose ‘yes’. 

 

 

 

 

 

 

 

 

 

• LM358N has two parts, A and B and we should place both by clicking twice. 

SEARCH IN LIBRARIES 
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Notice: The difference between the ‘Header 2’ and the ‘Header 2H’ parts are only in the footprint created on the 
PCB later. Some parts will need to be rotated and this can be accomplished by pressing the spacebar while you 
are placing the part or when the part is selected. Try to place the parts more or less like the following screenshot.  

 

 

 

 

 

 

 

 

ADDING PARTS AND MODIFYING THE SCHEMATIC  
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Notice: The ‘Header 2H’ 
part has been rotated as 
well as mirrored in order 
to get the 1 pin on top 
when the part is in this 
orientation. Rotation is 
accomplished with the 
spacebar key while the 
mirror is added by right-
clicking the part and 
checking the ‘mirrored’ 
checkbox. This does not 
make any difference on 
the PCB file it just makes 
your schematic easier to 
view and understand.  

Part has been rotated as 
well as mirrored in 
order to get the 1 on top 
and 2 below 

Parts have been rotated 
using the spacebar key 



ADDING PARTS AND MODIFYING THE SCHEMATIC  

It is now time to wire these 
parts together.  

a. You can either click the 
‘Place Wire’ icon from the upper 
toolbar or select Place > Wire. 
Both are illustrated here.  

 
b. Once you click this icon your 
cursor will turn into a crosshair 
with a black X on it. Once you 
hover over a valid place to 
connect a wire the X will turn 
red. If the X does not turn red 
when you place the wire a 
proper connection was not 
made and this will lead to 
errors later in the process. 
The red X is illustrated close up 
here.  
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ADDING PARTS AND MODIFYING THE SCHEMATIC  

c. Using the ‘Place Wire’ tool add wires between the components just like the image shown below  

 
 
 
 
 
 
 
 
 
 
 

d. Once a connection between two points is made the ‘Place Wire’ cursor will be ready to select the next 
beginning point.  
e. When you are finished placing wire either press the Esc key or right-click the mouse to return the cursor to 
normal and stop adding wires.  
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POWER AND GROUND NETS 

• Now it’s time to add the Power and Ground nets to the schematic  

a. Click the ‘VCC Power Port’ button that is next to the ‘Place Wire’ button and place (4) of them in the 
places shown in the image on the next page  

i. ports will be renamed from ‘VCC’ to ‘+12V’. Naming ports the same thing is the same thing 
as connecting them with a wire but it is a more elegant solution for keeping the 
schematic less congested.  

ii. To rename a port just double click on the port and its properties dialog box will pop up. You 
can then change the text in the ‘Net’ textbox in order to change the name of the net. Shown 
below.  
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POWER AND GROUND NETS 

• Click the ‘GND Power Port’ button next to the ‘Place Wire’ button and place (5) of them in the schematic in 
the places shown in the image on the next page  

 

 

 

 

 

 

 

 

 
 

This image shows the Power (+12V) and Ground (GND) nets added to the schematic with red arrows  
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NET LABELS 

• Now we will use named nets to add connections to our schematic without wires. 
a. Click on the ‘Place Net Label’ icon next to the place wire icon –OR- click Place > Net Label. 
b. Use spacebar to rotate the net label to make it easier to place. 
c. Place nets in the places shown in the image below. 

d. In order to rename the net Double click it –OR- Right click and select Properties then change the 
value in the textbox for Net 

  In our case the net name will be either Input or Output 

30 



ANNOTATION 

It is now time to annotate all of the unnamed components  

a. Add more descriptive comments to the ports, this will make them easier to find on the PCB later 

i. Change the comment on the input port that reads ‘Header 2H’ and make it say ‘Input’  

ii. Change the comment on the output port that reads ‘Header 2’ and make is say ‘Output’  

iii. Change the comment on the power port that reads ‘Header 2’ and make is say ‘Power’  

b. No two components are allowed to have the same designator we must rename them; this can be 
accomplished one-by-one or this can be done automatically  

i. You can do this for each component by hand. Go to the properties of each component and change the 
text in the Designator field  

ii. –OR- You can do them all at once automatically using tools in Altium (much easier)  

1. Tools > Annotate Schematics Quietly  

2. Click OK when the dialog box pops up to tell you how many changes will be made  

3. This will automatically add unique designators to each component depending on the annotation 
rules that are currently in place  

4. You may optionally change the annotation rules using Tools > Annotate Schematics if you 
want more control over the way the program decides to rename you designators for you. That is 
out of the scope of this tutorial 
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ANNOTATION 

Your schematic should look something like the one below without any question marks on it  
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Question 
marks are 
gone and 

components 
have unique 

names 

New port comments 



ADDING PARTS AND MODIFYING THE SCHEMATIC  

Now, we should change the “value” of each component according to our design. 

• Double click on each component and change the * character to the appropriate value and click OK. 

• Make sure the comment is visible. (Figure 21). Your design would be similar to figure below. 
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Figure 21 

ADDING PARTS AND MODIFYING THE SCHEMATIC  



ADDING PARTS AND MODIFYING THE SCHEMATIC  

Now the Schematic is ready and we can design the PCB file.  

Before transferring to PCB, make sure your schematic design has no error. 

 in Project > Compile PCB project ‘nameOfProject.PrjPcb’ 

When the project is compiled, all warnings and errors will displayed in the Messages panel. The panel will only 
appear automatically if there are errors detected. If there are errors, work through each one, checking your 
circuit and ensuring that all wiring and connections are correct. 

Here we have floating input pins which are for second part of Op-Amp and should wire as voltage follower. 
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FINAL SCHEMATIC 
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MAKING AND MODIFYING PCB FILE  

We are now ready to update the PCB file  

a. Design > Update PCB Document ‘nameOfProject.PcbDoc’  

b. Scroll to the bottom of the window that pops up and uncheck the box next to the room that the 
program is trying to add  

c. Click Validate Changes, make sure all of the changes get validated  

d. Click Execute Changes, this will add all of the components and nets to your PCB document  

e. Close the update window (Figure 23) 

 

The PCB file should have automatically opened for you; if not, open it now  

a. Click View > Fit Sheet to see the board as well as all of your components  

b. You will notice that the components are added outside of the board area (black area)  

c. The components can be dragged onto the board as you place them  
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Figure 23 



COMPONENT PLACEMENT 

We will now arrange the components on the board  

a. Go to the PCB document  

b. Begin dragging the footprints of the components over to the board  

i. The footprints and the designators can once again be rotated using Spacebar while they are being dragged  

ii. To get a better view at any time you can use View > Fit Document or you can use Page Up and Page Down 
(or Ctrl+Scroll) to zoom in and out at any time   

iii. The designators of the components can be dragged independently of the component in order to make the 
PCB document easier to read at times  

iv. The comments or the designators from the schematic file can be added to or removed from the PCB by 
opening the properties of the component on the PCB document and checking or unchecking the hide box 
under the ‘Designator’ and ‘Comments’ sections.  

v. As you drag a component around the board you will notice thin lines connecting the nodes of the component 
to other nodes around the board. These lines will jump to the closest connection that can be made on the 
board. Take notice of these lines and attempt to keep them short and if they are crossed try rotating the 
component until the lines are straight.  

vi. Try to arrange your components in a compact design as many manufacturing houses will charge you 
depending on the size of the board. You will get better at this the more you use the software. For an example 
of the layout look at the image below  
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REDEFINE BOARD SHAPE 

• Redefine the board shape (The black background on the screen is the board)  

a. View > Board Planning Mode 

b. a green screen will appear. Then go to Design > Redefine Board Shape 

c. The cursor will turn into a crosshair  

d. Zoom in to get a closer view of the grid and click the first corner of the new board shape that you 
want; continue to the next corner and click again; once you return to the first corner that you clicked 
on there will be a circle around the crosshair letting you know that you are back where you started; 
Once you are finished either Right-click or press Esc in order to stop redefining the board. 

e. View > 2D Layout Mode. The board should look something like the image below  
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COMPONENT PROPERTIES 

• You may hide/show Designator 
and Comment of each 
component. Double click on the 
component and this window will 
appear.    
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DESIGN RULES 

a. Open the rule wizard using Design > 
Rule  

b. In the ‘Routing’ select ‘width’ and 
change the constraints to: 

Min Width: 20mil (0.5 mm)  

Preferred Width: 20mil (0.5 mm) 

Max Width: 40mil (1 mm) 

c. in ‘Electrical’ select ‘Clearance’ and 
change the ‘Minimum Clearance’ to 
20mil (or 0.5mm). 

42 

Note: check “ECE Protel Design Guide” file and follow the design rule 
settings according to the instruction. It is available on ECE webpage. 

 

Change the design rule of the board to define Track Width and Clearance 

 



ROUTING 

• Let’s start routing: 

• Place > Interactive Routing ; The cursor will turn into a crosshair  

• Start from a pad and find a suitable path to the destination which is defined by a thin line. 

• You can change track angles by pressing spacebar while being in ‘place track’ mode. 

• Remember to zoom in/out to have a better view of the pads during routing. 

• Using via in case of moving from top layer to bottom layer and vice versa. 
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CONFIGURATION 

Add your initials and a revision number 
a. Use Place > String to add the string to an empty space on your board  

b. Double click the string to open its properties  

i. Change the text field to your course name and group number  

 i.e. ‘Course name - Group number’  

Add a keepout layer to the perimeter of your board 
 some manufactures will use this to cut your board  

a. Select ‘Keep-Out Layer’ from the tabs at the bottom of the designer window; up to this point we 
have been working from the ‘Top Layer’  

b. b. Make sure the Keepout layer is selected then Add a Line using Place > Line. This will be 
similar to redefining the shape of the board where you can zoom in at the corners to make sure 
you are clicking the right spot and then zoom back out to get to the next corner more quickly.  

c. c. Add the Line to the perimeter of the board and then press Esc to stop adding the track. The 
keepout Line should be pink because it is on the keepout layer. 

 

 

 

 

 

44 



DESIGN RULE CHECK 
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• Design Rule Checking (DRC) is a powerful 
automated feature that checks both the 
logical and physical integrity of your 
design. Checks are made against any or all 
enabled design rules. 

• Go to Tools > Design Rule Check 

• The report lists each rule that was tested, 
as specified in the Design Rule 
Checker dialog. Each violation that was 
located is listed with full details of any 
reference information, such as the layer, 
net name, component designator and pad 
number, as well as the location of the 
object. 

• When you run Design Rule Check, a new 
window will open. (Figure 22) 



DESIGN RULE CHECK 
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Figure 22 



ALTIUM PCB POLYGON POUR INSTRUCTION 

After your PCB has been routed and you are ready to pour copper on the top and bottom layers: 

• Click the Place tool bar button and select “PolyGon Pour…”.  

• Set the layer to Top Layer and also set the “Connect to Net” to your ground net. Tick ‘Remove 
Dead copper’ and ‘Is Poured’ then Click OK. (F.20) 

• Your mouse pointer will change to a cross hair. Use this pointer to draw a box around your PCB. 
After drawing a box around your PCB right click your mouse to exit the draw mode. 

• Altium will fill the empty areas of your top layer on your PCB with copper connected to ground.  

• We need to repeat this procedure for the bottom layer.   
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ALTIUM PCB POLYGON POUR INSTRUCTION 
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Figure 20 



ALTIUM PCB POLYGON POUR INSTRUCTION 
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• The board will be like image below: 

  

 

  Top Layer     

 

 

 

 

 

     Bottom Layer 

 



FINAL VIEW 
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ANY QUESTION? 
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